[Davical-general] Installing Davical under Mageia 4

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Davical-general] Installing Davical under Mageia 4

Graeme Gemmill
I have progressed to the stage where
http://192.168.1.9/davical/setup.php gives me one amber line and one red
line:
Versions installed are awl: 0.55
                                     davical 1.1.3.1
and I have run update-davical-database.
The amber line says
DAViCal DB Schema version     Want: 1.2.11, Currently: 1.2.12
which I don't understand given the new installations.
The red line says
Suhosin "server.strip" disabled     Fail
so I added the following lines to /etc/php.ini
[suhosin]
php_admin_flag suhosin.server.strip off
without noticeable effect.
I welcome your suggestions.
Thanks
Graeme

------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general
Reply | Threaded
Open this post in threaded view
|

Re: Installing Davical under Mageia 4

Vincent Van Houtte
Graeme schreef op di 27-01-2015 om 12:28 [+0000]:
> I have progressed to the stage where
> http://192.168.1.9/davical/setup.php gives me one amber line and one red
> line:
> Versions installed are awl: 0.55
>                                      davical 1.1.3.1
> and I have run update-davical-database.
> The amber line says
> DAViCal DB Schema version     Want: 1.2.11, Currently: 1.2.12
> which I don't understand given the new installations.

This looks like a bug: if your version is newer than the expected
version, there should be no problem with your setup.

> The red line says
> Suhosin "server.strip" disabled     Fail
> so I added the following lines to /etc/php.ini
> [suhosin]
> php_admin_flag suhosin.server.strip off
> without noticeable effect.
> I welcome your suggestions.

These are the options I have set in my virtualhost-file:
...
        DirectoryIndex  index.php index.html
        AcceptPathInfo  On
        php_value       magic_quotes_gpc 0
        php_value       register_globals 0
        php_value       error_reporting 1
        php_value       default_charset "utf-8"
        php_admin_flag  suhosin.server.strip off
        php_value       magic_quotes_runtime 0
...

These allow me to have all requirements marked green (except for PHP
curl, but I don't need it). Do you have 'php5-suhosin' (Debian)
installed?

Kr,
Vincent
--
Vincent Van Houtte
Advocaat
Advocatenkantoor Suy, Van Baeveghem & Van Houtte
Brusselsestraat 108
9200 Dendermonde
T +32(0)52 52 06 05
T +32(0)52 77 90 05
F +32(0)52 52 06 46
W http://synergylaw.be


------------------------------------------------------------------------------
Dive into the World of Parallel Programming. The Go Parallel Website,
sponsored by Intel and developed in partnership with Slashdot Media, is your
hub for all things parallel software development, from weekly thought
leadership blogs to news, videos, case studies, tutorials and more. Take a
look and join the conversation now. http://goparallel.sourceforge.net/
_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general