Quantcast

[Davical-general] Ubuntu 16.04 PHP 7.0 Postgres 9.5 Davical

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Davical-general] Ubuntu 16.04 PHP 7.0 Postgres 9.5 Davical

Martin Haltmayer
Dear all,

searched the archives to no avail.

Since upgrading my Ubuntu 14 to 16.04 (Xeria?) my Thunderbird's (38.4.0) Lightning ceases to connect to any of the previously working calendars.

Symptoms:

(1) The postgres upgrade from 9.3 to 9.5 went fine.

(2) The upgrade script for davical went fine with the proper davical_dba owner.

(3) The setup interface http://myserver/setup.php displays all tests as "Passed".

(4) The management interface http://myserver/index.php asks for entering credentials. I can enter davical_app and my password or any other credential
of the calendar users. All display the complete list of users.

(5) I can connect directly at the server as postgres user to the davical database by

psql davical davical_app

and launch several select statements against davical_dba's tables, e. g. usr, principal, caldav_data, calendar_item etc. All display the expected
number of entries.

(6) I can configure one or several CalDAV calendars in lightning with the URL

http://myserver/caldav.php/principal/calendar/

I am asked for the credential which I can successfully enter. However, Thunderbird fails to display any of the entries seen in (5).

(7) When attempting to add a new appointment, I just get a small yellow triangle indicating that the calendar is temporarily not available. No further
diagnostics at the client side.

At the server side, however, I see in /var/log/apache2/other_vhosts_access.log:

myserver:80 my_ip - principal [10/Oct/2016:02:16:18 +0200] "PUT /caldav.php/principal/calendar/8b2ebad2-211f-4f15-89c4-1522334e4548.ics HTTP/1.1" 201
444 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0 Lightning/4.7.4"
myserver:80 my_ip - principal [10/Oct/2016:02:16:18 +0200] "REPORT /caldav.php/principal/calendar/ HTTP/1.1" 500 427 "-" "Mozilla/5.0 (Windows NT
10.0; WOW64; rv:45.0) Gecko/20100101 Thunderbird/45.4.0 Lightning/4.7.4"

which is a HTTP 500 error. No clue why.

(8) Note: I can run successfully:

myserver:/usr/share/davical/htdocs# curl --request PROPFIND  --user "principal:password" http://myserver/caldav.php
<?xml version="1.0" encoding="utf-8" ?>
<multistatus xmlns="DAV:">
 <response>
  <href>/caldav.php/</href>
  <propstat>
   <prop>
    <getcontenttype>httpd/unix-directory</getcontenttype>
    <resourcetype>
     <collection/>
    </resourcetype>
    <displayname>Haltmayer's DAViCal Server</displayname>
    <getlastmodified>Thu, 01 Jan 1970 00:00:00 GMT</getlastmodified>
    <creationdate>19700101T000000Z</creationdate>
    <getcontentlanguage/>
    <supportedlock>
     <lockentry>
      <lockscope>
       <exclusive/>
      </lockscope>
      <locktype>
       <write/>
      </locktype>
     </lockentry>
    </supportedlock>
    <owner>
     <href>/caldav.php/principal/</href>
    </owner>
    <current-user-principal>
     <href>/caldav.php/principal/</href>
    </current-user-principal>
   </prop>
   <status>HTTP/1.1 200 OK</status>
  </propstat>
 </response>
</multistatus>

Hmm. Any help appreciated about that HTTP 500.

Regards, Martin

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 PHP 7.0 Postgres 9.5 Davical

Martin Haltmayer
Hi Andy,

thanks, that did the trick!

Regards,

Martin



Am 10.10.2016 um 09:13 schrieb Andreas Schiller:

> Hi Martin,
>
>> Since upgrading my Ubuntu 14 to 16.04 (Xeria?) my Thunderbird's (38.4.0) Lightning ceases to connect to any of the previously working calendars.
> My Upgrade to Ubuntu Xenial is some months ago. I remember having a similar problem, and when I'm right on this I believe installing php7.0-xml was
> the solution.
>
> HTH & Greetz,
> Andy
>
>


------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Ubuntu 16.04 PHP 7.0 Postgres 9.5 Davical

Florian Schlichting-2
Hi,

On Mon, Oct 10, 2016 at 09:41:43AM +0200, Martin Haltmayer wrote:
> thanks, that did the trick!
>
> Am 10.10.2016 um 09:13 schrieb Andreas Schiller:
> >> Since upgrading my Ubuntu 14 to 16.04 (Xeria?) my Thunderbird's (38.4.0) Lightning ceases to connect to any of the previously working calendars.
> > My Upgrade to Ubuntu Xenial is some months ago. I remember having a similar problem, and when I'm right on this I believe installing php7.0-xml was
> > the solution.

JFTR: since a week or two, there is a fixed davical package in
xenial-updates waiting for the next 16.04 point release. So hopefully
this won't bite too many other people in the future!

Florian

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general
Loading...