[Davical-general] unable to apt-get into wheezy due to dependency issue

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[Davical-general] unable to apt-get into wheezy due to dependency issue

Maurizio Marini
apt-get install davical
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 davical : Depends: libawl-php (< 0.54) but 0.54-1 is to be installed
E: Unable to correct problems, you have held broken packages.



# apt-cache showpkg davical
Package: davical
Versions:
1.1.1-1 (/var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_binary-amd64_Packages) (/var/lib/apt/lists/debian.mcmillan.net.nz_debian_dists_wheezy_awm_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_binary-amd64_Packages
                  MD5: 19435e49abceef5cd47325c39800ed1c
 Description Language: en
                 File: /var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_i18n_Translation-en
                  MD5: 19435e49abceef5cd47325c39800ed1c


Reverse Depends:
Dependencies:
1.1.1-1 - debconf (2 1.0.32) php5-pgsql (0 (null)) postgresql-client (2 8.1) libawl-php (2 0.53-1~) libawl-php (3 0.54) libdbd-pg-perl (0 (null)) libyaml-perl (0 (null)) postgresql (2 8.3)
Provides:
1.1.1-1 -
Reverse Provides:




many thnx

-m


------------------------------------------------------------------------------
Subversion Kills Productivity. Get off Subversion & Make the Move to Perforce.
With Perforce, you get hassle-free workflows. Merge that actually works.
Faster operations. Version large binaries.  Built-in WAN optimization and the
freedom to use Git, Perforce or both. Make the move to Perforce.
http://pubads.g.doubleclick.net/gampad/clk?id=122218951&iu=/4140/ostg.clktrk
_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general
Reply | Threaded
Open this post in threaded view
|

Re: unable to apt-get into wheezy due to dependency issue

Jim Fenton
There was some discussion on this list last fall about the libawl-php dependency problem.

Check this discussion thread; hopefully it contains some info that will help:

http://sourceforge.net/p/davical/mailman/davical-general/thread/5231DC4E.8080301%40markula.org/#msg31395500

-Jim

On 03/06/2014 08:16 AM, Maurizio Marini wrote:
apt-get install davical
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 davical : Depends: libawl-php (< 0.54) but 0.54-1 is to be installed
E: Unable to correct problems, you have held broken packages.



# apt-cache showpkg davical
Package: davical
Versions:
1.1.1-1 (/var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_binary-amd64_Packages) (/var/lib/apt/lists/debian.mcmillan.net.nz_debian_dists_wheezy_awm_binary-amd64_Packages)
 Description Language:
                 File: /var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_binary-amd64_Packages
                  MD5: 19435e49abceef5cd47325c39800ed1c
 Description Language: en
                 File: /var/lib/apt/lists/ftp.debian.org_debian_dists_wheezy_main_i18n_Translation-en
                  MD5: 19435e49abceef5cd47325c39800ed1c


Reverse Depends:
Dependencies:
1.1.1-1 - debconf (2 1.0.32) php5-pgsql (0 (null)) postgresql-client (2 8.1) libawl-php (2 0.53-1~) libawl-php (3 0.54) libdbd-pg-perl (0 (null)) libyaml-perl (0 (null)) postgresql (2 8.3)
Provides:
1.1.1-1 -
Reverse Provides:




many thnx

-m



------------------------------------------------------------------------------
Subversion Kills Productivity. Get off Subversion & Make the Move to Perforce.
With Perforce, you get hassle-free workflows. Merge that actually works. 
Faster operations. Version large binaries.  Built-in WAN optimization and the
freedom to use Git, Perforce or both. Make the move to Perforce.
http://pubads.g.doubleclick.net/gampad/clk?id=122218951&iu=/4140/ostg.clktrk


_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general


------------------------------------------------------------------------------
Learn Graph Databases - Download FREE O'Reilly Book
"Graph Databases" is the definitive new guide to graph databases and their
applications. Written by three acclaimed leaders in the field,
this first edition is now available. Download your free book today!
http://p.sf.net/sfu/13534_NeoTech
_______________________________________________
Davical-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/davical-general